View Issue Details

IDProjectCategoryView StatusLast Update
0016795phplist applicationMessage Managementpublic29-05-13 13:16
Reporterdymitar 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.9 
Target VersionFixed in Version2.11.10 
Summary0016795: utf-8 issues in text generation
DescriptionThere is an issue in generating text version of the message from html.
The problem is related to line 24 in generatetext.php

The code
$textversion = htmlentities($textversion);

should be changed to
$textversion = htmlentities($textversion,ENT_QUOTES,'UTF-8');
Steps To Reproduce--Enter html text (tab 1) in language, other than english (multibyte characters)
(In the specific case cyrillic)
-- go to tab 2 and press "generate from html"
-- the result on the screen is wrong
(the result in the database is correct)

-- Change the code as described
-- perform the same steps
-- the result is correct

See the attached screenshot
TagsNo tags attached.

Activities

dymitar

29-05-13 12:51

reporter  

sample.jpg (109,028 bytes)
sample.jpg (109,028 bytes)

michiel

29-05-13 13:16

manager   ~0052051

great find! Thanks. Applied to SVN/GIT