View Issue Details

IDProjectCategoryView StatusLast Update
0016782phplist applicationpluginspublic03-05-13 01:28
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.9 
Target Version2.11.10Fixed in Version2.11.10 
Summary0016782: Update plugin does not overwrite directory
DescriptionWhen updating a plugin the php rename() function does not appear to reliably overwrite an existing directory. On both linux and windows (WAMP) the rename fails for a directory which already exists, but does replace a file that already exists.

see file admin/plugins.php line 108

It is not a permissions problem because I can install and remove the plugin, and then install it again.

Possibly need to treat an update as a remove followed by an install to avoid this problem.
TagsNo tags attached.

Activities

support

01-05-13 20:16

administrator   ~0052022

good you found that

michiel

03-05-13 01:28

manager   ~0052027

interesting in a way. Wonder if this is a PHP bug. The docs say on "rename":

Attempts to rename oldname to newname, moving it between directories if necessary. If newname exists, it will be overwritten.

but obviously that was not the case.