View Issue Details

IDProjectCategoryView StatusLast Update
0016754phplist applicationInstallationpublic21-03-13 21:40
Reporterduncanc 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.11.7 
Target VersionFixed in Version2.11.8 
Summary0016754: Populating the new link tracking tables after a database upgrade
DescriptionProblem found in SVN trunk version.

I upgraded an existing 2.10.18 database.

The new link tracking tables were created but they were not populated from the existing tables.

There was no reference to those tables. Only by looking at the code did I find a page called convertstats that does the population.

However a link to that page is on only the statsmgt page, but is actually disabled due to convertstats being in a list of disallowed pages in setpermissions.php.

After an upgrade there needs to be a clearer indication of how to populate the new link tracking tables.


TagsNo tags attached.

Activities

michiel

21-03-13 21:40

manager   ~0051966

set the convert page to be allowed and added a notice in "upgrade" to use it when there is data to convert