View Issue Details

IDProjectCategoryView StatusLast Update
0016747phplist applicationPlugin APIpublic18-03-13 16:30
Reporterduncanc 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.7 
Target VersionFixed in Version2.11.8 
Summary0016747: Plugin directory PLUGIN_ROOTDIR not recognised
DescriptionProblem found in SVN trunk.

The plugin directory in PLUGIN_ROOTDIR is not used because PLUGIN_ROOTDIRS is always defined, even as an empty string.

In init.php line 139
if (!defined('PLUGIN_ROOTDIRS')) define('PLUGIN_ROOTDIRS','');

In pluginlib.php line 10

$pluginRootDirs = array();
if (defined('PLUGIN_ROOTDIRS')) {
  $pluginRootDirs = explode(';',PLUGIN_ROOTDIRS);
} else {
  $pluginRootDirs = array(PLUGIN_ROOTDIR);
}

So PLUGIN_ROOTDIR is never used.
The solution is to remove the line from init.php
TagsNo tags attached.

Activities

michiel

18-03-13 16:30

manager   ~0051951

I took out the else, and append the PLUGIN_ROOTDIR always, just so it's always used