View Issue Details

IDProjectCategoryView StatusLast Update
0016706phplist applicationAttachmentspublic28-11-12 15:20
Reporterdubwise259 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu OS Version10.04 LTS
Product Version2.11.7 
Target VersionFixed in Version2.11.8 
Summary0016706: EMBEDUPLOADIMAGES functionality
DescriptionI'm still unable to get embedded image, even with the new version of class.phpmailer.php provided by michiel in issue 0016702
https://mantis.phplist.com/view.php?id=16702

Path/URL now looks like http://phplist_url/upload/image/my_logo.jpg, so image is properly displayed with its full url path but it is not embedded / encoded in base64, only powerphplist.png is embedded.


Steps To ReproduceFresh install phplist 2.11.7
Start a new message, add an image to the content and send a test message.
Email receiver can see the image but if you look at the source code, image is not embedded.
Additional InformationAs issue 0016702 had been closed, I've had to open a new issue.
TagsNo tags attached.

Relationships

related to 0016702 resolvedmichiel Embedded image in content not working 

Activities

michiel

31-10-12 11:22

manager   ~0051814

are you sending your queue with commandline or in-browser?

presumably commandline. For commandline, it needs to save the "Image Path" in the DB, because that's not available without the Webserver.

Can you check the DB and see the value for:

select value from phplist_config where item = "uploadimageroot";

dubwise259

05-11-12 16:25

reporter   ~0051857

I'm sending the queue from the browser using "send test" button.
I've checked the value of the field "uploadimageroot", it was empty so I put the same value as in config.php
Then I send another test message but nothing changed, image appears well because url is correct but message's source code reveals that it is not embedded, only "powerphplist.png" is embedded.
Regards

cmeerendonk

28-11-12 14:50

reporter   ~0051925

The / is missing between the docroot and uploadimagesdir in function filesystem_image_exists. This should solve it:

diff class.phplistmailer.php.org class.phplistmailer.php
427,428c427,428
< is_file($_SERVER['DOCUMENT_ROOT'].UPLOADIMAGES_DIR.'/image/'.$localfile)
< || is_file($_SERVER['DOCUMENT_ROOT'].UPLOADIMAGES_DIR.'/'.$localfile)
---
> is_file($_SERVER['DOCUMENT_ROOT'].'/'.UPLOADIMAGES_DIR.'/image/'.$localfile)
> || is_file($_SERVER['DOCUMENT_ROOT'].'/'.UPLOADIMAGES_DIR.'/'.$localfile)

michiel

28-11-12 15:20

manager   ~0051926

thanks for finding that

revision 3483