View Issue Details

IDProjectCategoryView StatusLast Update
0016702phplist applicationAttachmentspublic31-10-12 11:18
Reporterdubwise259 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu ServerOS Version10.04 LTS
Product Version2.11.7 
Target VersionFixed in Version2.11.8 
Summary0016702: Embedded image in content not working
DescriptionHi all,
Fresh install of version 2.11.7 / PHP 5.3
When adding an image to the content section of a message :
--> image appears fine in FCKeditor
--> path/URL looks like /upload/image/my_logo.jpg
Then I send a test message :
--> receiver gets no image
--> when looking at the source, image path is local (/upload/image/my_logo.jpg), that's why it's not showing anything and is clearly not embedded
--> source code reveals that only "powerphplist.png" is embedded (base64 encoded)

When using a template with an image in the content section, same problem appears, image path remains local and image is not embedded.

Adding the following parameters to /config/config.php define("EMBEDUPLOADIMAGES",1); has no effect.

Steps To ReproduceStart a new message, add an image to the content and send a test message.
TagsNo tags attached.

Relationships

related to 0016706 resolvedmichiel EMBEDUPLOADIMAGES functionality 

Activities

michiel

25-10-12 12:55

manager   ~0051784

ah, yes, you can Google that one to find a patch. There are a few people out there who solved this, without telling anyone else about it (well, apart from blogging about it).

It's one line that needs to change somewhere. Not sure any more which one. Will try to look it up later.

dubwise259

26-10-12 14:44

reporter   ~0051787

Ok, i've tried to find a solution on google but no success.
If you find something, let us know.
I can't do more test of this version until we find a patch.
Thanks.

michiel

26-10-12 14:56

manager   ~0051788

ah, hang on, sorry, this is the EMBEDUPLOADIMAGES functionality.

I'll check it out now

michiel

26-10-12 18:18

manager   ~0051789

It works for me on trunk, but I'm not sure what changed since 2.11.7. I didn't think anything in this area changed, but I may be wrong. In the process I discovered an issue on having subdirectories in the UPLOADIMAGES_DIR config which I fixed now.

The post that may help is http://www.flashme.com.au/flashmeblog/web-design-issues/phplist-uploading-images-fckeditor-and-absolute-path-urls/

michiel

26-10-12 20:21

manager   ~0051790

it worked when sending test mails, but not when sending the queue from commandline. That's fixed now. You can get the latest class.phplistmailer.php and replace it. http://phplist.svn.sourceforge.net/phplist/?rev=3373&view=rev

It'll only work when using UPLOADIMAGES_DIR not FCKIMAGES_DIR