View Issue Details

IDProjectCategoryView StatusLast Update
0016695phplist applicationDocumentation - Configurationpublic19-10-12 22:16
Reportermwest 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSUbuntu ServerOS Version12.04
Product Version2.11.7 
Target VersiondocumentationFixed in Version2.11.8 
Summary0016695: SSL/TLS
Descriptionclass.phpmailer.php can use SSL/TLS enabled smtp servers but there is no mention in the documentation or FAQ.
Steps To ReproduceUhm, not currently documented in the configuration, help or FAQ
Additional InformationThe following details should be documented somewhere in the configuration docs or added to the FAQ. PHPMailer can handle SSL/TLS smtp auth. Only 2 globals need to be added to enable this feature.

In lists/admin/class.phplistmailer.php
change:
          $this->SMTPAuth = true;
          $this->Username = $GLOBALS['phpmailer_smtpuser'];
          $this->Password = $GLOBALS['phpmailer_smtppassword'];
to:
          $this->SMTPAuth = true;
          $this->Username = $GLOBALS['phpmailer_smtpuser'];
          $this->Password = $GLOBALS['phpmailer_smtppassword'];
     # these two globals enable SSL/TLS support
          $this->SMTPSecure = $GLOBALS['phpmailer_smtpsecure'];
          $this->Port = $GLOBALS['phpmailer_smtpport'];

In lists/config.php
change:
          #$phpmailer_smtpuser = 'smtpuser';
          #$phpmailer_smtppassword = 'smtppassword';
to:
          $phpmailer_smtpuser = 'smtpuser';
          $phpmailer_smtppassword = 'smtppassword';
    # phpmailer_smtpsecure should be 'y' to turn on SSL/TLS support
    # set this to 'n' to turn off SSL/TLS support
          $phpmailer_smtpsecure = 'y';
    # default smtpsecure port is '587'
          $phpmailer_smtpport = '587';

I doubt it would be really required to change the code base. Simply adding this information to the configuration documents would be sufficient.

Thank You

TagsNo tags attached.

Activities

michiel

18-10-12 20:40

manager   ~0051756

that's great, thanks, good point. The docs wiki is currently out of action, because the wiki was overloading the server, but hopefully people will find this mantis entry as well

mwest

18-10-12 22:10

reporter   ~0051758

need to change the phplist version. I just realized I was in the latest stable. So the above hack is for the latest stable. [2.10.19]

I'm looking over 2.11.7 now. I already see some changes with regards to port. I'm looking further to see what other changes there are.

mwest

19-10-12 16:09

reporter   ~0051760

Ok, in the dev version [2.11.7] SMTPSecure is already setup in class.phplistmailer.php.

In lists/config.php
Right below:
      $this->Username = $GLOBALS['phpmailer_smtpuser'];
      $this->Password = $GLOBALS['phpmailer_smtppassword'];

Add:
      # if using SSL/TLS set this to y
      define("PHPMAILER_SECURE",'y');

and of course port will need to be configured but that part is self documented and mentioned in the FAQ.

michiel

19-10-12 22:16

manager   ~0051762

Is this sufficient? Or does it need more explanation?

http://phplist.svn.sourceforge.net/phplist/?rev=3360&view=rev