View Issue Details

IDProjectCategoryView StatusLast Update
0016691phpList 3 applicationpluginspublic30-10-12 20:53
Reporterduncanc 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.11.7 
Target VersionFixed in Version 
Summary0016691: rssmanager plugin vetoes sending any message to any user
DescriptionThe canSend() method in the rssmanager plugin returns false for a message that is not an rss message. This means that processqueue doesn't send to any users when that plugin is enabled (which is the default if you set the plugin directory).

I guess that there needs to be some wrapper logic along these lines

if the message is an rss message
   do what it currently does
else
    return true

Additionally looking at the current code this looks odd, it seems to be comparing a frequency (daily, weekly etc) with an rss template id.

    if ($userdata['rssfrequency'] == $messagedata["rsstemplate"]) {
TagsNo tags attached.

Relationships

duplicate of 0016657 resolvedmichiel Enabling Plugins causes messages to fail to send 

Activities

duncanc

14-10-12 08:48

updater   ~0051746

Ignore the last comment about the frequency. The field rsstemplate on the message table does actually contain a frequency.

michiel

14-10-12 17:33

manager   ~0051747

Yes, it would be good to finish off the RSS manager. At the moment it's kind of a cut-n-paste from the original code, but it'll need a bit of tweaking to fit the plugin system properly.

Thanks, it sounds like you're running tests on this, which is very useful to come across stuff like you did here.