View Issue Details

IDProjectCategoryView StatusLast Update
0016680phplist applicationEmailpublic27-10-12 16:06
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.7 
Target Version2.11.8Fixed in Version2.11.8 
Summary0016680: List-Unsubscribe header has escaped &
DescriptionHeaders such as List-Unsubscribe are now added to each email.

This example looks wrong because the & has been escaped to & even though the url is not within html.
The specification here http://www.faqs.org/rfcs/rfc2369.html shows examples without escaping.

List-Unsubscribe: <http://strontian/lists2.11.7/?p=unsubscribe&uid=b0ea147a3e5cee2ca5b4a32ba8655265>

TagsNo tags attached.

Activities

duncanc

04-09-12 09:22

developer   ~0051718

Mantis has failed to escape the & so the example now looks correct.
This is what it should look like

List-Unsubscribe: <http://strontian/lists2.11.7/?p=unsubscribe&amp;uid=b0ea147a3e5cee2ca5b4a32ba8655265>

michiel

26-10-12 22:09

manager   ~0051794

it's not just the List-Unsubscribe header, it's all the links in the text version (which is where the List-Unsubscribe header is taken from)