View Issue Details

IDProjectCategoryView StatusLast Update
0016670phplist applicationCommand Linepublic04-06-13 21:36
Reporterdanjfoley 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformapacheOSfreebsdOS Version
Product Version 
Target Version2.10.20Fixed in Version2.11.10 
Summary0016670: command line won't run as the unregister gloabls clear all command line parameters
DescriptionSee https://mantis.phplist.com/view.php?id=15288

it's the same problem.
Steps To ReproduceTry running anything on the command line.
TagsNo tags attached.

Activities

danjfoley

10-08-12 00:26

reporter   ~0051700

I have fixed by adding this line to the unregister_globals functions.. first line inside the function:

if (php_sapi_name() == "cli") return;

That way nothing gets unregistered when running via command line.

Works for me. Again it's the same issue above that was reported fix in 2.10.11

PS i'm running 2.10.19 and it's still not fixed.