View Issue Details

IDProjectCategoryView StatusLast Update
0016649phplist applicationInterface - Administratorpublic31-05-13 13:05
Reporterraynau 
PrioritylowSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformW2KOSW2KOS VersionW2K
Product Version2.10.18 
Target VersioninternationalizationFixed in Version2.11.10 
Summary0016649: Problem with the term users which is used in different places
Descriptionand can have different meanings.

The term users is used in many places of the menu.
First it is used in the main menu and file used for translation is common php.
When you use in the menu manage users, you again get in the menu the term users and the translation is always the one used in common.php.
A translation was included in the file : usermgt.php, but it has been deleted because it was the same word.

All that mixture was source (spring) of problem for translation, because the main menu is changing when you use some parts of it.

In order to make it clear, here is how I have managed to resolve the problem.

1°) In file usermgt.php, line 7 which was written :
get('users')).$spe; => I have changed it as follows :
get('users2')).$spe;

2°) In file usermgt.php in lan, the first line which was not used because translation was supposed to come from common.php (line 4), I have put that line runnin again as follows :
'users2' => 'users' ; or your translation for the submenu which allows you to go to users management.
I have translated the term users2 as : See the list of all the users.

May be my explanations are not very clear, but the point was that you have to explain the term users in usermgt.php and this translation makes confusion with the translation used in common.php. So it is better to use two different terms.
Files which have a small change are :
usermgt.php under admin (line 7)
usermgt.php in each language where line 4 the term user2 must be translated.
TagsNo tags attached.

Activities

raynau

23-06-12 17:29

reporter  

usermgt-en-under-lan.php (Attachment missing)

raynau

23-06-12 17:30

reporter  

usermgt-fr-under-lan.php (Attachment missing)

raynau

23-06-12 17:30

reporter  

usermgt-under-admin.php (Attachment missing)

michiel

31-05-13 13:05

manager   ~0052070

translations, and terms (even english) can be changed in the translation site http://translate.phplist.com