View Issue Details

IDProjectCategoryView StatusLast Update
0016636phpList 3 applicationInterface - Administratorpublic30-05-13 22:49
Reporterraynau Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformw2kOSw2kOS Versionw2k
Product Version2.10.18 
Target VersioninternationalizationFixed in Version2.11.10 
Summary0016636: file : pagetitles.php in any language
DescriptionFor that page which shows the title in any sheet which is seen, a headline has been forgotten for the page : usermgt.
I have made a line for french language of course..:)
and I join you the file in english on which a line which is numbered 23 has been added.
In english it comes out as follows : but review the interpretation :
case 'usermgt': $page_title = 'Users management';break;
TagsNo tags attached.

Activities

raynau

30-05-12 01:16

reporter  

pagetitles.php (3,196 bytes)   
<?php
switch ($page) {
  case 'home': $page_title = 'Main Admin Page';break;
  case 'setup': $page_title = 'Configuration Options';break;
  case 'about': $page_title = 'About '.NAME;break;
  case 'attributes': $page_title = 'Configure Attributes';break;
  case 'stresstest': $page_title = 'Stress Test';break;
  case 'list': $page_title = 'The List of Lists';break;
  case 'editattributes': $page_title = 'Configure Attributes';break;
  case 'editlist': $page_title = 'Edit a list';break;
  case 'checki18n': $page_title = 'Check that translations exist';break;
  case 'import4': $page_title = 'Import emails from a remote database';break;
  case 'import3': $page_title = 'Import emails from IMAP';break;
  case 'import2':
  case 'import1':
  case 'import': $page_title = 'Import emails';break;
  case 'export': $page_title = 'Export users';break;
  case 'initialise': $page_title = 'Initialise the database';break;
  case 'send': $page_title = 'Send a Message';break;
  case 'preparesend': $page_title = 'Prepare a message for sending';break;
  case 'sendprepared': $page_title = 'Send a prepared message';break;
  case 'members': $page_title = 'List Membership';break;
  case 'usermgt': $page_title = 'Users management';break;
  case 'users': $page_title = 'List of All users';break;
  case 'reconcileusers': $page_title = 'Reconcile users';break;
  case 'user': $page_title = 'Details of a user';break;
  case 'userhistory': $page_title = 'History of a user';break;
  case 'messages': $page_title = 'list of messages';break;
  case 'message': $page_title = 'View a message';break;
  case 'processqueue': $page_title = 'Send message queue';break;
  case 'defaults': $page_title = 'Some useful default attributes';break;
  case 'upgrade': $page_title = 'Upgrade '.NAME;break;
  case 'templates': $page_title = 'Templates in the system';break;
  case 'template': $page_title = 'Add or Edit a template';break;
  case 'viewtemplate': $page_title = 'Template Preview';break;
  case 'configure': $page_title = 'Configure '.NAME;break;
  case 'admin': $page_title = 'Edit an Administrator';break;
  case 'admins': $page_title = 'List Administrators';break;
  case 'adminattributes': $page_title = 'Configure Administrator attributes';break;
  case 'processbounces': $page_title = 'Retrieve bounces from server';break;
  case 'bounces': $page_title = 'List bounces';break;
  case 'bounce': $page_title = 'View a bounce';break;
  case 'spageedit': $page_title = 'Edit a subscribe page';break;
  case 'spage': $page_title = 'Subscribe pages';break;
  case 'eventlog': $page_title = 'Log of events';break;
  case 'getrss': $page_title = 'Retrieve RSS feeds';break;
  case 'viewrss': $page_title = 'View RSS Items';break;
  case 'community': $page_title = 'Welcome to the PHPlist community';break;
  case 'vote': $page_title = 'Vote for PHPlist';break;
  case 'login': $page_title = 'Login';break;
  case 'logout': $page_title = 'Log Out';break;
  case 'mclicks': $page_title = 'Message Click Statistics'; break;
  case 'uclicks': $page_title = 'URL Click Statistics'; break;
  case 'massunconfirm': $page_title = 'Mass Unconfirm emails';break;
}
?>
pagetitles.php (3,196 bytes)   

raynau

30-05-12 02:18

reporter   ~0051644

Same problem with the file : massunconfirm in most foreing languages.
line
case 'massunconfirm': $page_title = 'Mass Unconfirm emails';break;
should be added to most foreing languages in file : pagetitles.php

michiel

30-05-12 12:42

administrator   ~0051645


yes, there will be loads more missing. If you can find them, that would be great.

Remember to work on latest svn code, not on 2.10.X

raynau

30-05-12 15:38

reporter   ~0051646

Normally, all pages titles are ok now, except if you make a new sheet.

I cannot work on 2.11 because it is written in UTF-8 and in that way I cannot clearly understand what I write and what I read. Moreover before finishing a correction, in most times, I make a trial, then I change, then I change it again for being correct. In fact there are always three or four writings which are necessary in order to correctly understand the meaning of the menu... etc...
I am waiting for the program being hardly finished, then I shall review it. That means, to make it working in Iso, correct it and then putting it again in UTF-8.

If the bases are the same than in 2.10 (texts to be translated), then, it won't be a problem.

michiel

30-05-13 22:49

administrator   ~0052064

pagetitles.php is obsolete. Use the "pagetitle:X" in the translation site instead