View Issue Details

IDProjectCategoryView StatusLast Update
0016581phpList 3 applicationInternationalization (l18n)public31-05-13 12:45
Reporterraynau 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionduplicate 
Platformw2kOSw2kOS Versionw2k
Product Version2.10.18 
Target VersioninternationalizationFixed in Version 
Summary0016581: The big bug,
Descriptionor the big problem.
Everything works fine except one point.

Sending in text mode.

When you past a text coming from winword or any text system, all the letters are correct except the ' which is changed in : ’
If you type the text, you have not the problem.

If you copy the text from a html sheet the ' is translated correctly.

I have tried also in UTF-8, but there are other problems : menus and processing info are not sent correctly (letters are missing). In fact it comes out worst globally when running in UTF-8 : some menu are not correctly converted such as the subject in messages and when you try to forward the letters are not correct.

In fact, the big point is the ' which is not written correctly in text mode.

Tried a lot of things but it does not work.

In html, it is perfect.
TagsNo tags attached.

Relationships

duplicate of 0016614 new converting some characters from Word to text format fails 

Activities

raynau

09-04-12 02:33

reporter   ~0051542

I have understood where is coming the problem.
The problem is not coming from PHPlist, but from the fact that winword or some others program register the characters ' and - in a different way than the normal way.
Then it is not correctly translated and there is an error.

You know everything, and it is up to you.