View Issue Details

IDProjectCategoryView StatusLast Update
0016575phpList 3 applicationSubscriber Importpublic22-05-12 13:54
Reportersamtuke Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.11.6 
Summary0016575: Error: Running DEV version, but developer_email not set
DescriptionRunning 2.11.6 (not an option in "Product Version".

This error is shown when trying to add a new subscriber to any list:

Error: Running DEV version, but developer_email not set

This is fixable by by adding the following to config.php:

define(DEVVERSION, 0);

This is a nasty workaround however, as the running version is in fact a dev version. I don't know of any way to set the developer email, or what impact doing so would have.

Please either remove this check, or add a check for the required dev email during installation, or at least add a way to set the email from the configuration pages. Thanks!
TagsNo tags attached.

Relationships

duplicate of 0015588 resolvedmichiel Send process requires change to test mode then back to send 

Activities

michiel

29-03-12 15:40

administrator   ~0051533


that's strange. I think that version detects "dev" from the VERSION define in "connect.php". Check that it's set to 2.11.6 and not to "2.11.6-dev".

Setting developer_email can be done in the config file:

$developer_email = 'email address';

However, that will cause all emails to be sent to this address, which is probably not what you want.

samtuke

29-03-12 16:43

administrator   ~0051536

OK, that's useful. But isn't this a bug if PHPList dev versions are publicly downloadable / usable, but they cannot actually be used for sending messages unless undocumented vars are added to config.php?

Solutions might be:
- Don't use -dev for versions publicly available, even if they're dev versions
- Require users to choose whether dev mode is enabled during installation
- Add a notice on the dashboard about dev mode being enabled with a link to change this
- Don't allow dev mode to be enabled without a dev email being configured
- Don't require a dev-email for adding subscribers in dev mode

Just my 2c.

michiel

29-03-12 21:28

administrator   ~0051538

yes, that would be a bug, which is why I'm confused you encountered this. 2.11.6 is actually already fairly old, and it's not been reported before. I have installed it in several places.

Solution is (a) do not use dev for public versions.