View Issue Details

IDProjectCategoryView StatusLast Update
0016562phpList 3 applicationBounce Managementpublic07-06-13 20:30
Reporterraynau 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformwk2OSWK2OS VersionWK2
Product Version2.10.17 
Target VersioninternationalizationFixed in Version 
Summary0016562: File bounce php
Descriptionand command : DeletingB line 11 in the file.

Message read is : Deleting bounce 56 ..\n..Done, ...
after 56, there is something which does not fit : ..\n..
It should stop at 56 in the exemple, put a dot and then go on with Done etc..

It should be : Deleting boune 56. Done etc...
TagsNo tags attached.

Activities

duncanc

24-03-12 12:06

developer   ~0051518

The \n is intended to put the message on a line on its own. It needs to be in double quotes, not single, "\n".

duncanc

24-03-12 12:17

developer   ~0051520

Lines 75 and 79 of file admin/bounce.php need to be changed.

raynau

24-03-12 13:22

reporter   ~0051521

In Bounce.php in lang directory it is written as follows : line 11
 "DeletingB" => "Deleting bounce %s ..\n",

If you put the n between double quotes, it won't fit, because the " is already used for delimitation instead of the '.
Or is it to write line 75 and 79 as follows ?
75 as print sprintf($GLOBALS['I18N']->get('DelUser')."\n", $userid);
75 written now :print sprintf($GLOBALS['I18N']->get('DelUser').'\n', $userid);

79print sprintf($GLOBALS['I18N']->get('DeletingB')."\n", $id);
79 written now :print sprintf($GLOBALS['I18N']->get('DeletingB').'\n', $id);

duncanc

24-03-12 13:46

developer   ~0051522

Ah, as usual it is more complex than I thought.
As you reported, there is a literal \n in the message, so lines 75 and 79 need to be changed to either remove it or change it to "\n" for a new-line.

But the DeletingB message text already includes a \n correctly inside double-quotes, so it is probably not needed at all on line 79.

The developers need to decide on the best solution.

raynau

24-03-12 14:03

reporter   ~0051523

Well, in my opinion it is not compulsory to change line for the message.
I have fixed it as follows :
"DeletingB" => "Suppression de l'envoi numéro %s revenu en erreur.",
I translate :
"DeletingB" => "Deleting sending-message having the number %s which came back in error.",

Well for once it is easier to write in french than to translate into english.

In fact you do a message, then the same message has a number according to the number of people to who it is sent. If you send it to two people, then you have message-sent n° 1 then message-sent n° 2.

raynau

24-03-12 16:41

reporter   ~0051525

Well after changing in the bounce fr file, I have made an other trial.
It comes out as follows :

Suppression de l'envoi numéro 57 revenu en erreur.\n. .C'est fait, chargement du prochain message revenu en erreur.

retour vers la liste d'emails rejetés

In fact, on that point too, the translation is not correct, it should be messages returned.

And it comes out that the changes must be done in the file bounce under admin, because I have deleted the n wich was included in the translation.

raynau

25-05-12 02:35

reporter   ~0051626

This problem is resolved by someone who has given me the solution as follows :

line 79 of bounce.php is now written as follows :
print sprintf($GLOBALS['I18N']->get('DeletingB'), $id);echo "\n";

and it works perfectly, so you can include it and make the appropriate correction