View Issue Details

IDProjectCategoryView StatusLast Update
0016546phpList 3 applicationphpListpublic31-05-13 12:47
Reporterraynau 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformw2kOSw2kOS Versionw2k
Product Version2.10.17 
Target VersioninternationalizationFixed in Version 
Summary0016546: Characters pasted in FCKeditor come out wrong
Description
3°) There is a problem for message pasted from word in Fckeditor when messages are sent in text : the ' is not converted correctly.
If the message is typed, there is no problem. If the message is sent in Html, there is no problem. When the text is pasted in Fckeditor, it looks good, but when arriving in text mode, the problem comes out.


Additional Informationoriginal report.

1°) Between the forum, the translation, the report for bugs, it should be easier to have only one login and one password, because at the end, except if you note and take care of everything you cannot find your eggs as a chicken :).

2°) More seriously : sending a message with an attached document. Message taken from winword and paste from winword into FCkeditor.
Sometimes, I do not know why, only the attached document is sent and not the message etc. But it is not constant, so I shall see later.
The important point is : suppose an attached document is sent and the consignee use outlook for having his mail.
When the message is sent in Html mode, the attached document is perfectly attached in the area which is made for that. If the message is sent in text mode, there is a line at the bottom of the message which makes that you do not see at ounce that there is an attached document and if the message has been deleted from the server, you cannot get it.
Proposal : should be good to use the same method for attached documents whatever be the mode in which the message is sent (txt or html).

3°) There is a problem for message pasted from word in Fckeditor when messages are sent in text : the ' is not converted correctly.
If the message is typed, there is no problem. If the message is sent in Html, there is no problem. When the text is pasted in Fckeditor, it looks good, but when arriving in text mode, the problem comes out.


3°) I am going to begin to study the problem of the number of messages which can be sent with mailqueue, batch, batchsize etc... It does not seem to me to be clear for the time being. There are explanations, but when you start of zero, I have to understand how it runs to make it running the quickest possible.
But there are explanations in the forum.

4°) For the translation in UTF8, I think I have understood. Parts of info and help must be written in UTF-8, but there is no effect on the character ' which can be left as it is.

Best regards


TagsNo tags attached.

Relationships

duplicate of 0016614 new phpList 3 application converting some characters from Word to text format fails 
related to 0015414 resolvedmichiel phpList 3 plugins Use ckeditor instead of FCKEditor 
related to 0016700 new phpList 3 application blank messages on hotmail 

Activities

michiel

03-03-12 17:45

manager   ~0051483

would be good to make one mantis issue per issue. And PLEASE make the subject a concise summary of the issue. https://www.google.com/search?q=how+to+report+bugs

1. yes, indeed. World peace would be nice as well :-) Just to remind you, this is an open source project with limited means. But if you're happy to write the integration of the systems, let me know.

2. Well, in order to attach to a text email, the text email would have to be MIME. The whole point of text emails is to keep them small. Adding the attachment would be against that. Text emails are for ppl on slow internet connections and with bad email readers. What if you're on an EDGE connection (or satellite phone) and you get a 5Mb attachment in your email. You'd be terribly pissed off. Instead, you'd want to read the text and then decide whether or not to get the attachment. You could even forward it to someone else to get it.

So, it works like this by design, and as long as I'm the core architect, that's not going to change.

I do agree the link could be higher up, but I think there's an issue for that already.

3-1st: I guess that's the real problem identified in this issue.

3-2nd: yes, that's a good idea.

4: ok

raynau

03-03-12 20:26

reporter   ~0051484

2) For messages sent in text mode, put the link as the first line looks in my opinion as the best solution.
I had not thought about the other problems which are perfectly right : phones, low connections etc... with which I do agree.