View Issue Details

IDProjectCategoryView StatusLast Update
0015625phplist applicationHTML Email Supportpublic02-11-12 18:39
Reportermichiel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.11.6 
Target Version4.0.xFixed in Version2.11.8 
Summary0015625: extraneous paragraph tag
DescriptionWhen composing a message (step 1 of sending a
campaign), the custom HTML gets embedded in a P-tag container. This is
completely unnecessary. If you want a P-tag container around your message
you can do that yourself. That's what the option to enter custom HTML is for
right? Also it doesn't fit well into email-html best practices, i.e. use
tables for structure, and as a P-tag is block level it's better not to have
it inside a table cell (TD).
TagsNo tags attached.

Activities

marcelvanduijn

19-07-11 09:07

reporter   ~0051378

Problem Replication: create a new campaign -> in step 1 click 'source' to enter source directly -> Type something -> now toggle the source btn: when you are back to the actual source field there is a P-tag around what you entered.

Note that I did not check yet if the P-tag is also included in the mails that are send-out (I'm a bit busy at the moment). But at least it happens in the web-interface, which is confusing anyway.

Chrs

michiel

08-08-11 15:20

manager   ~0051389

related to http://dev.ckeditor.com/ticket/1537

I think this will be resolved with the efforts to integrate a later version of the Ckeditor.

michiel

25-10-11 12:31

manager   ~0051416

in a way, this is caused by the editor trying to keep the content xhtml compatible.

I tried this, and it seemed to work:

1. Create campaign
2. Click "source" in the editor
3. Enter "<div class="content">Hello in div in source</div>"
4. Click "source" again.

going back to "source" does not have the P added to the content.

michiel

02-11-12 18:39

manager   ~0051847

the P-tag is no longer there using FCKeditor 2.6.8