View Issue Details

IDProjectCategoryView StatusLast Update
0015612phplist applicationSubscribe Processpublic19-05-11 16:32
Reporterchrisedes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.13 
Target Version2.10.XFixed in Version2.10.13 
Summary0015612: Attributes' order of listing on subscribe page cannot be saved (not fixed in 2.10.13)
DescriptionI am having the same problem described in ticket #15285. The issue was supposedly fixed in 2.10.11, but I'm running 2.10.13 and I am experiencing the same issue.

http://mantis.phplist.com/view.php?id=15285
TagsNo tags attached.

Relationships

duplicate of 0015614 resolvedmichiel Configuring Attributes does not save order, default, and, required 
related to 0015285 resolvedmichiel v2.10.10: Attributes' order of listing on subscribe page cannot be saved 

Activities

chrisedes

11-05-11 21:47

reporter   ~0051304

My install was an upgrade from 2.10.9 . I thought that might be a factor, so I installed a fresh copy of 2.10.13 to test with. Unfortunately, the same problem exists in a fresh install of 2.10.13 .

chrisedes

11-05-11 22:01

reporter   ~0051305

Linux (Fedora Core 8)
Apache version 2.2.9
MySQL version 5.10.45
PHP version 5.2.6

chrisedes

11-05-11 22:02

reporter   ~0051306

Sorry, that's MySQL version 5.0.45

chrisedes

11-05-11 22:34

reporter   ~0051307

Upgraded original installation to 2.10.14 . I am experiencing the same problem in 2.10.14 .

michiel

12-05-11 18:39

manager   ~0051326


must be something else then, it works fine for me on http://demo.phplist.com/lists/admin/?page=spageedit&id=4

chrisedes

12-05-11 19:11

reporter   ~0051327

The demo.phplist.com link is to a 2.11.6 version...?

chrisedes

12-05-11 19:12

reporter   ~0051328

Here's my install: http://libertyordeath.us/phplist_test/?p=subscribe

Login with admin/phplist if you want to play around with it. This is a fresh install. The only things I did were: (1) add DB connection info, (2) take it out of test mode, (3) configure the plugin location, and (4) set it to use the session table in the DB so I don't have to log in repeatedly.

chrisedes

12-05-11 19:12

reporter   ~0051329

I looked at the source code of the generated subscribe page on my end. Not sure if it's relevant, but the various attributes have id's of "attribute1", "attribute2" etc. This is the order in which I added the attributes. However, this is not the order in which they are displayed on the page.

chrisedes

12-05-11 19:24

reporter   ~0051332

This is weird. I created a new subscribe page to see if that would work better. However, when I did that the new page did not display any of the attributes at all, in any order. Not only that, but the default page also stopped displaying the attributes!

When I deleted the custom subscribe page, the default page started displaying the attributes again.

chrisedes

12-05-11 19:32

reporter   ~0051333

Oops... I did not notice the checkboxes that say "Check this box to use this attribute in the page." Now it works and is in the correct order!

That's weird that it changes the default subscribe page though, and makes the attributes stop displaying.

This clarifies things. For a custom subscribe page, everything works fine. It is only the default subscribe page whose order cannot be changed.

michiel

12-05-11 21:24

manager   ~0051335


what do you mean with default subscribe page? The one that is generated when no subscribe pages exist at all? Or the one that is marked "default" in the list of subscribe pages?

chrisedes

12-05-11 21:26

reporter   ~0051336

The one that is generated when no subscribe pages exist at all.

michiel

12-05-11 21:38

manager   ~0051337

ok, thanks, I'll look at that later

michiel

12-05-11 21:52

manager   ~0051338

just tried, but even that works. The order in that case is the order as set in the attributes page.

michiel

19-05-11 16:31

manager   ~0051353

continues on 0015614