View Issue Details

IDProjectCategoryView StatusLast Update
0015600phplist applicationHTML Email Supportpublic31-10-12 19:52
Reportermichiel 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.12 
Target Version4.0.xFixed in Version2.11.8 
Summary0015600: Backslashes are stripped from HTML messages
Descriptionkenh reports that:
==== Start Quote ====
My problem is that the last message I sent out had some examples that included a file path like this:
C:\Windows\SysWOW64\odbcad32.exe

When I saved the message the backslashes were gone. So I put them back in and when I saved they were gone again. So I put in double slashes and then saved. It went to single slashes. Next save removed them completely.
==== End Quote ====
ref: http://forums.phplist.com/viewtopic.php?p=80173#p80173
Additional InformationI ran a test and can confirm this issue for HTML messages.
Plain text messages seem to be fine, at least when the 'manual text part' setting is enabled in config.php. Haven't tested automatic parsing into text messages.
TagsNo tags attached.

Relationships

related to 0015551 resolvedmichiel Backslashes are stripped from HTML messages 

Activities

michiel

28-04-11 19:11

manager   ~0051187

applied to stable, but needs reviewing in trunk, because too much has changed in trunk and patch doesn't apply without loads of conflicts