View Issue Details

IDProjectCategoryView StatusLast Update
0015581phplist applicationInternationalization (l18n)public31-10-12 12:36
Reportersolmar 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPhplist 2.11OSLinuxOS VersionCentOS
Product Version2.11.5 
Target Version4.0.xFixed in Version2.11.7 
Summary0015581: Apostrophe in translation breaks variable, makes un-blacklisting from admin impossible
DescriptionUsing Italian translation distributed with this version.
File Admin\Lan\It\Userhistory.php

Row 9's translation includes an escaped apostrophe ("dell\'utente"). Formally this is correct, but at run time, it somehow impedes a Javascript pop-up to be launched, making it impossible to un-blacklist users from the admin.

Solution: change the translation with something that does not use the apostrophe, i. e. "dell\'utente" -> "del proprietario"
Then, the pop-up is launched normally.
Steps To ReproduceSwitch to Italian language > blacklist an e-mail > go to admin > search for this user > view details > view history > click "remove from blacklist" > no pop-up
TagsNo tags attached.

Relationships

duplicate of 0015489 resolvedmichiel Can't remove a user from blacklist when working with Italian localization 

Activities

michiel

28-04-11 21:56

manager   ~0051193

"resolved" in stable in 0015489, but will be good to sort out better in dev