View Issue Details

IDProjectCategoryView StatusLast Update
0015542phplist applicationStatisticspublic01-02-12 23:56
Reporterangelo95 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux X86OSCentOSOS Version5.2
Product Version2.10.12 
Target Version2.10.XFixed in Version2.11.6 
Summary0015542: When Click Tracking enabled, [UNSUBSCRIBE] doesn't work anymore
DescriptionI have just noticed that the [UNSUBSCRIBE] links generated in the signature doesn't work anymore when click tracking is enabled:

404 Not Found
The requested document was not found on this server
Please contact the Administrator
Steps To ReproduceTo reproduce, simply send yourself a test message with the [UNSUBSCRIBE] tag and try clicking on the message. Do this with click tracking enabled and disabled in config.php
Additional InformationI have done this test on my production server and a fresh install. Both give the same result.

I upgraded to 2.10.12 from 2.10.9 which had the same issue.
TagsNo tags attached.

Relationships

related to 0015360 resolvedmichiel Click Tracking is not working for links in the body of the message, only for those in the footer. 
related to 0015573 resolvedmichiel Clicking Link in message renders error 404 
related to 0015523 resolvedmichiel Click tracking & [USERTRACK] Not Functioning 

Activities

h2b2

16-01-11 15:34

manager   ~0051150

A number of other users reported the same issue in this forum thread: http://forums.phplist.com/viewtopic.php?f=17&t=29344

vdrews suggests the issue might be caused by a configuration error in pageroot and adminpages:

==== Start quote ====
I found the mistake!!
In my config.php file, the values of pageroot & adminpages were wrong! (Someone else set phplist up, so it took me some time to even consider that it might be something wrong with the setup … :-S)
I have no clue what exactly happens here, but I guess that's why all the links get changed when setting CLICKTRACK to 1.

The (for me) correct version is:
$pageroot = '/lists';
$adminpages = '/lists/admin';

(it was '/lists/index.php' & '/lists/admin/index.php' – don't ask me why …)
check it for yourself!

To use the wrong path here has an effect on various functions & stuff in phplist but obviously you don't necessarily notice it in the first place, because the most functions will work.
==== End quote ====
source: http://forums.phplist.com/viewtopic.php?p=82216#p82216

michiel

29-04-11 15:34

manager   ~0051210

I've added a warning in the config file about tampering with the pageroot variable.

http://phplist.svn.sourceforge.net/phplist/?rev=2675&view=rev

but I suspect there's more the matter. When I add the "index.php" to the pageroot, I get tracking links like this:

/lists/index.php/lt.php?id=XXX

which basically loads the top subscribe page and doesn't give a 404

michiel

29-04-11 17:00

manager   ~0051215


would be good to get some more data on how to reproduce this. If anyone can add some examples on how to do that that would be great.