View Issue Details

IDProjectCategoryView StatusLast Update
0015534phplist applicationMessage Send Processpublic22-05-12 15:14
Reporterjeremyw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.5 
Target Version4.0.xFixed in Version2.11.7 
Summary0015534: Newlines in footer converted to "rn" in text input box when saving a new message
DescriptionWhen a new message draft is saved, newlines are converted to "rn". Presumably there is a bug somewhere with escaping.

Steps To Reproduce1. From the admin page, start a new campaign. Message footer should appear correctly in text input box.
2. "Save Changes."
3. Footer in text box now appears all on one line, with newlines replaced with "rn".
TagsNo tags attached.

Relationships

related to 0015522 resolvedmichiel Cannot select a destination list 

Activities

jeremyw

25-08-10 04:00

reporter   ~0051074

It may be relevant that in my PHP environment, magic_quotes_gpc = false.

jeremyw

25-08-10 06:30

reporter   ~0051076

Yes, it's a problem resulting from having magic quotes off. Leaving them off, I tried commenting out the sql_escape() line in admin/lib.php (line 62), and the message footer saved correctly.

Not sure what the best course of action is here for a permanent solution.

jeremyw

25-08-10 14:16

reporter   ~0051077

Further to my last note, I *think* the sql_escape() line in setMessageData() in admin/lib.php (line 62) can be safely removed, because the data it escapes is escaped again when it is used later in the function by Sql_Replace() (line 90).

Removing sql_escape() at line 62 also renders the patch I provided for issue #0015522 (http://mantis.phplist.com/view.php?id=15522) unnecessary.