View Issue Details

IDProjectCategoryView StatusLast Update
0015532phplist applicationSubscribe Processpublic22-05-12 14:09
Reporterjeremyw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.5 
Target Version4.0.xFixed in Version2.11.7 
Summary0015532: Subscribe process fails due to output() statements in class.phplistmailer.php
DescriptionIf PHPlist is configured to use PHPMailer, the subscription process fails abruptly while attempting to send the confirmation email. A user who submits his/her email address and newsletter selection will sees only the "subscribe page" header.
Steps To Reproduce0. Configure PHPlist 2.11.5 to use PHPMailer.
1. Go to the subscribe page (e.g., http://YOURDOMAIN/lists/?p=subscribe) and sign up for a newsletter.
2. After hitting "submit," only header of "subscribe page" template appears.
Additional InformationCulprit undefined output() function called by MailSend() in class.phplistmailer.php, in three places. These calls were added since PHPlist 2.11.3. By the look of things they were inserted for debugging purposes.

Problem can be fixed by commenting out the output() calls.
TagsNo tags attached.

Activities

solmar

06-02-11 21:58

reporter   ~0051163

Confirm this solution works for us. Using 2.11.5 with PHPmailer.

michiel

22-05-12 14:09

manager   ~0051579

was probably already ok in 2.11.6