View Issue Details

IDProjectCategoryView StatusLast Update
0015527phpList 3 applicationConfigurationpublic21-06-18 14:00
Reporterruddcl Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version2.11.5 
Summary0015527: Upgrading database from 2.11.5 to 2.11.5
DescriptionDatabase error 1064 while doing query You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'repeat repeatinterval integer default 0' at line 1
Error, unable to rename column "repeat" in the table phplist_message to be "repeatinterval"
Please do this manually, refer to http://mantis.phplist.com/view.php?id=9001 for more information
Information: Success
Tagsdocumentation

Relationships

related to 0009001 resolvedmichiel "Database error 1054" when viewing list members 

Activities

michiel

30-05-12 18:54

administrator   ~0051649


that will have to go into documentation.

It has to do with a table column being called "repeat" which in earlier versions wasn't a reserved word, but since Mysql 4 is.

So, older databases may have the "repeat" column in the phplist_message table, which has to be renamed "repeatinterval"