View Issue Details

IDProjectCategoryView StatusLast Update
0015517phplist applicationMessage Managementpublic23-05-12 16:14
Reporterduncanc 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.11.5 
Target Version4.0.xFixed in Version2.11.7 
Summary0015517: Cannot see or edit message body for a new message
DescriptionAfter upgrading to 2.11.5 the system does not display the Message Body field for editing.
See this topic in the forum including a screenshot

http://forums.phplist.com/viewtopic.php?f=17&t=32446

TagsNo tags attached.

Activities

duncanc

19-07-10 16:41

developer   ~0051061

Looked a bit further into this and the problem seems to be in function loadmessagedata() in lib.php. This function has changed dramatically from version 2.10.12.

The element sendmethod is initialised to 'remoteurl' - not sure why though

    'sendmethod' => 'remoteurl', ## make a config

Later on it is set to 'inputhere' only if the message field is non-empty - which won't be true for a new message

  if (empty($messagedata['sendurl']) && !empty($messagedata['message'])) {
    # if there's a message and no url, make sure to show the editor, and not the URL input
    $messagedata['sendmethod'] = 'inputhere';
  }

In send_core.php some javascript is generatd that hides the message content if the sendmethod is not 'inputhere'

  if (isset($messagedata['sendmethod']) && $messagedata['sendmethod'] != 'inputhere') {
    $maincontent .= '<script type="text/javascript">$("#messagecontent").hide()</script>';
  }
So for a new message the content area is hidden.

I really like using phplist but when looking at the code a lot of it seems really woolly and not thought out properly.

duncanc

26-07-10 19:36

developer   ~0051062

Looked even further and the problem seems to be caused by not having the class HTTP_Request installed.

In send_core.php line 564 there is a test of $GLOBALS['has_pear_http_request'] that is false and means that the radio buttons to select between URL and directly entered message are not displayed.
As noted above the sendmethod is set to 'remoteurl' and there then is no way to change it.

h2b2

27-07-10 22:40

manager   ~0051063

My 2.11.5 test system is also missing the HTTP_Request module, and I was able to reproduce this issue.
The workaround suggested by duncanc seems to work fine, and will display the editing window.
ref: http://forums.phplist.com/viewtopic.php?p=77877#p77877

vrocks

30-07-10 10:38

reporter   ~0051064

I am also having this issue.

michiel

23-05-12 16:14

manager   ~0051611

In svn sendmethod defaults to "inputhere". Not sure when that changed, but that seems to resolve this.