View Issue Details

IDProjectCategoryView StatusLast Update
0015509phplist applicationPlugin APIpublic31-05-12 13:18
Reporterh2b2 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version4.0.xFixed in Version2.11.7 
Summary0015509: Plugin: Monitor progress during sending of messages
DescriptionMonitoring progress during mailqueue processing is a feature regularly asked for in the forums, and may help signal issues during sending, like script timeouts.
Ideally, the plugin should be able to:
1) display sending progress,
2) detect sending issues, and show warning messages with useful info about the cause of these issues.

Point 2 may require that the phpList error reporting system be made ready to provide error codes to plugins.


Additional InformationA useful progress monitoring plugin was developed by robodigital and CS/CS2, and could be considered a good first step forward:

==== Start quote ====
It'll show the number sent for all messages with status of either "inprocess" or "suspended" along with their status, id and subject.
==== End quote ====

Attached plugin: msgprogress.zip
ref: http://forums.phplist.com/viewtopic.php?p=44827#p44827
TagsNo tags attached.

Relationships

child of 0003292 new plugin API functionality 

Activities

03-07-10 17:20

 

msgprogress.zip (827 bytes)

michiel

31-05-12 13:18

manager   ~0051661

that's now part of core