View Issue Details

IDProjectCategoryView StatusLast Update
0015489phplist applicationInternationalization (l18n)public28-04-11 20:52
Reportergerlos 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.12 
Target Version2.10.13Fixed in Version2.10.14 
Summary0015489: Can't remove a user from blacklist when working with Italian localization
DescriptionI'm working on a new installation of PHPlist, configured for using Italian as default language.
When go to the I try to the history page for an user to remove her/him from the blacklist, clicking on the link to remove from blacklist nothing happens.

If I use the drop-down menu to switch language to English, instead, this link works as it should, and I can remove the user from the blacklist.
TagsNo tags attached.

Relationships

has duplicate 0015581 resolvedmichiel Apostrophe in translation breaks variable, makes un-blacklisting from admin impossible 

Activities

h2b2

27-05-10 17:27

manager   ~0051024

Yes I can confirm this issue. The problem appears to be caused by a single quote mark used in the Italian backend translation. Though the single quote is escaped (\'), its use (escaped or not escaped) within a javascript popup is problematic.

You could try to fix this by editing lists/admin/lan/it/userhistory.php

At line 9, change this:
=> 'Questa operazione dovrebbe essere fatta unicamente con il consenso dell\'utente',

To this:
=> 'Questa operazione dovrebbe essere fatta unicamente con il consenso dell utente',

Please let us know if this solves the issue for you.

solmar

07-02-11 00:08

reporter   ~0051164

Confirm this solves the issue.
Done in version 2.11.5: problem gone.

gerlos

07-02-11 15:49

reporter   ~0051165

Thank you for solving this issue!

michiel

28-04-11 20:52

manager   ~0051192

http://phplist.svn.sourceforge.net/phplist/?rev=2660&view=rev

bit of a hacked solution, but considering this is "stable" it'll do.

would be good to sort out more thoroughly in dev code (ie a central JS function that handles it)