View Issue Details

IDProjectCategoryView StatusLast Update
0015476phpList 3 applicationCampaign Send Processpublic25-10-10 21:06
Reporterh2b2 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version2.10.12 
Target VersionFixed in Version2.11.5 
Summary0015476: Add a 'List-Unsubscribe' line to the email header to comply with RFC 2369
DescriptionAs a means to facilitate unsubscribing of mailing lists, several large mail providers recommend using the 'List-unsubscribe' header line in emails, as specified in RFC 2369.

Adding this feature would be in line with existing phpList policy, i.e. to give maximum subscription and unsubscription control to list subscribers.
Additional InformationRelated links:
http://www.list-unsubscribe.com/
http://www.faqs.org/rfcs/rfc2369.html
https://mail.google.com/support/bin/answer.py?hl=en&answer=81126#unsub
TagsNo tags attached.

Relationships

duplicate of 0015270 new [feature-request] List-Unsubscribe mailto: header as opposed to http:// 

Activities

h2b2

01-07-10 17:05

manager   ~0051048

CS2 developed this mod:

===== Start quote =====
I've created a mod that will add the List-Unsubscribe header to emails sent from PHPlist.

The List-Unsubscribe header includes either an email address or web page that can be used for unsubscribing. It allows mail clients that support it the ability to include an "unsubscribe" link or button. Hotmail currently supports this feature and gmail list having this header in their suggested guidelines for increasing delivery rates to gmail. For more information on the header, see this page: http://www.list-unsubscribe.com/

Note, this is not intended as a replacement for the [UNSUBSCRIBE] placeholder, but as a useful counterpart.

Find the following section in admin/class.phplistmailer.php (around line 25):

          $this->addCustomHeader("X-Mailer: phplist v".VERSION);
          $this->addCustomHeader("X-MessageID: $messageid");
          $this->addCustomHeader("X-ListMember: $email");
          $this->addCustomHeader("Precedence: bulk");



and place this code in there:

          $url = getConfig("unsubscribeurl");$sep = ereg('\?',$url)?'&':'?';
          $req = Sql_Fetch_Row_Query(sprintf("SELECT uniqid FROM %s WHERE email = '%s'",
                                              $GLOBALS["tables"]["user"],$email));
          $hash = $req[0];
          $unsubscribeurl = sprintf('%s%suid=%s',$url,$sep,$hash);
          $this->addCustomHeader("List-Unsubscribe: $unsubscribeurl");

====== End Quote ======
source: http://forums.phplist.com/viewtopic.php?p=61772#p61772

h2b2

22-10-10 06:37

manager   ~0051131

Feature appears to have been added in v2.11.5. Changing status to 'feedback'

h2b2

25-10-10 21:06

manager   ~0051133

Duplicate of 15270. Closing issue.