View Issue Details

IDProjectCategoryView StatusLast Update
0015472phpList 3 applicationMessage Managementpublic16-11-18 12:16
Reporterduncanc 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product VersionFuture developments 
Target Versionnext majorFixed in Version 
Summary0015472: Add Duplicate message function
DescriptionThis topic in the forum has a patch to add a Duplicate function for a message
http://forums.phplist.com/viewtopic.php?f=7&t=13126&start=15

The function creates a copy of the selected message in draft status.

The patch code is very small and looks to work correctly. So I'd appreciate it being added to the core product to avoid having to apply it to each new version that I install.
TagsNo tags attached.

Relationships

duplicate of 0014994 closedsuela Add ability to copy an existing message 
duplicate of 0019263 resolvedsamtuke Copy previously sent message into draft 

Activities

michiel

12-05-11 00:33

manager   ~0051309


interesting. I always wanted to avoid something like that, in order to make sure that "novice" users of phpList wouldn't too easily duplicate emails to their subscribers.

So, I guess, we can add it, but maybe with a FLAG that's defaulted to off, so that only those who actively decide to add it, will have it.

duncanc

12-05-11 06:25

developer   ~0051314

Having used phplist for a year since I raised this request, I'm now not sure it is necessary. What I do is to edit an existing message, copy the source html, and then paste that into a new message.
If there is no other support for this request, which there doesn't seem to be, then I'm happy to drop it.

michiel

12-05-11 11:56

manager   ~0051315

well, we can leave it in, but low priority. There's so much else still to do ... :-)

lwc

14-10-13 21:36

updater   ~0052348

Be careful what you wish for, duncanc. I too used to edit an existing message, copy the source html, and then paste that into a new message. But v3+ no longer allows editing sent messages. See #16916.

You can view sent messages but copying them for example doesn't copy href links.