View Issue Details

IDProjectCategoryView StatusLast Update
0015439phplist applicationMessage Send Processpublic12-05-11 14:09
Reporterh2b2 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.10.10 
Target VersionFixed in Version2.10.15 
Summary0015439: Safe mode check in class.phpmailer.php may affect return-path header line
DescriptionReported by headalien on the forum: http://forums.phplist.com/viewtopic.php?f=17&t=29233#p70202

==== Start Quote ====
When trying to configure bounces and setting in phplist version 2.10.10

in config.php set and uncommented $message_envelope = 'putemailaddresshere';
Was still getting nobody@ for return-path and envelope in message headers.

Using mail() not smtp as outbound server.

Turns out there is a bug in admin/phpmailer/class.phpmailer.php
on approx line 437 this line always indicates that we are in safe mode and therefore never adds the custom headers

Code:
    if ($this->Sender != "" && strlen(ini_get("safe_mode"))< 1)

to fix change to
    if ($this->Sender != "" && ini_get("safe_mode")< 1)

Note that this works with php5 on linux....not sure about other setups

--Mitch
==== End Quote ====
TagsNo tags attached.

Relationships

duplicate of 0012625 resolvedmichiel safe_mode activity not correctly identified = sendmail_from wrong 
related to 0015170 resolvedmichiel Upgrading PhpMailer Class 
has duplicate 0015217 closed Confirmation emails are not sent 

Activities

h2b2

15-04-10 20:05

manager   ~0050907

Possibly related to 15273

michiel

12-05-11 14:03

manager   ~0051319

just checked and this incorrect safe mode identification still exists in phpMailer5.1

This should really be reported to phpMailer instead. If we patch it, it will reverse in the next upgrade.

there's an issue in phpMailer that is reported "fixed" that addresses it:

http://sourceforge.net/tracker/index.php?func=detail&aid=1158158&group_id=26031&atid=385707

I'll patch it the same way, in the hope it'll work in the future.