View Issue Details

IDProjectCategoryView StatusLast Update
0015432phplist applicationInterface - Backendpublic31-10-12 12:38
Reporteradrian15 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionFutureDevelopments 
Target Version4.0.xFixed in Version2.11.7 
Summary0015432: Upload images or any other file
DescriptionThese two patches:

- Fixes and enables images upload (please remove the pdf being a image type part manually)
- Enables any other file upload with the upload link

You might need to create uploadimages folder inside lists folder in order to work ok and maybe you might need to change their permissions.

This patch applies to svn revision 1703. And I use the FCKEditor version which was included in 2.10.10 stable release.
TagsNo tags attached.

Relationships

related to 0015482 resolvedmichiel [FCKeditor] SendError() is not defined in config.php 
related to 0015481 resolvedmichiel [FCKeditor] wrong path to phplist's config.php 

Activities

12-04-10 19:36

 

upload_any_image_or_file.tar (20,480 bytes)

14-04-10 15:47

 

C12_upload_images_final_fix.patch (2,089 bytes)
diff -urN linkaadmin_upload_images_final_before/lists/admin/FCKeditor/editor/filemanager/connectors/phplist/config.php linkaadmin_upload_images_final_after/lists/admin/FCKeditor/editor/filemanager/connectors/phplist/config.php
--- linkaadmin_upload_images_final_before/lists/admin/FCKeditor/editor/filemanager/connectors/phplist/config.php	2010-04-10 17:33:38.000000000 +0200
+++ linkaadmin_upload_images_final_after/lists/admin/FCKeditor/editor/filemanager/connectors/phplist/config.php	2010-04-10 17:37:13.000000000 +0200
@@ -149,7 +149,7 @@
 $Config['QuickUploadPath']['File']		= $Config['UserFilesPath'] ;
 $Config['QuickUploadAbsolutePath']['File']= $Config['UserFilesAbsolutePath'] ;
 
-$Config['AllowedExtensions']['Image']	= array('bmp','gif','jpeg','jpg','png','pdf') ;
+$Config['AllowedExtensions']['Image']	= array('bmp','gif','jpeg','jpg','png') ;
 $Config['DeniedExtensions']['Image']	= array() ;
 $Config['FileTypesPath']['Image']		= $Config['UserFilesPath'] . 'image/' ;
 $Config['FileTypesAbsolutePath']['Image']= ($Config['UserFilesAbsolutePath'] == '') ? '' : $Config['UserFilesAbsolutePath'].'image/' ;
diff -urN linkaadmin_upload_images_final_before/lists/admin/init.php linkaadmin_upload_images_final_after/lists/admin/init.php
--- linkaadmin_upload_images_final_before/lists/admin/init.php	2010-04-10 17:33:36.000000000 +0200
+++ linkaadmin_upload_images_final_after/lists/admin/init.php	2010-04-10 17:37:11.000000000 +0200
@@ -83,7 +83,7 @@
 if (!defined("USE_REPETITION")) define("USE_REPETITION",0);
 if (!defined("USE_EDITMESSAGE")) define("USE_EDITMESSAGE",0);
 if (!defined("FCKIMAGES_DIR")) define("FCKIMAGES_DIR","uploadimages");
-if (!defined('UPLOADIMAGES_DIR')) define('UPLOADIMAGES_DIR',FCKIMAGES_DIR);
+//if (!defined('UPLOADIMAGES_DIR')) define('UPLOADIMAGES_DIR',FCKIMAGES_DIR);
 if (!defined("USE_MANUAL_TEXT_PART")) define("USE_MANUAL_TEXT_PART",0);
 if (!defined("ALLOW_NON_LIST_SUBSCRIBE")) define("ALLOW_NON_LIST_SUBSCRIBE",0);
 if (!defined("MAILQUEUE_BATCH_SIZE")) define("MAILQUEUE_BATCH_SIZE",150); //Changed for test. (old value = 0)

adrian15

14-04-10 15:48

reporter   ~0050896

I have attached a third patch that:

Enables Image upload (which I had disabled by error in another patch).
Removes pdf from image filetype.

So if you combine the three patches you have got a nice: Upload any image or file patch. ;)

adrian15

h2b2

19-04-10 19:17

manager   ~0050927

Thanks Adrian,
Could you briefly mention which problem in revision 1703 is addressed with your patch? And whether or not this patch is relevant for release 2.10.12?

adrian15

19-04-10 21:42

reporter   ~0050936

Basically the problem is that:
* images upload from insert image icon in Fckeditor in send message page.
* upload a file from upload image icon in Fckeditor in send message page.

does not work out of the box.

I think that patch is relevant for 2.10.12 because I reused FCKEditor from 2.10.10 version and the changes in phplist-only files are minimal.

adrian15

h2b2

19-04-10 21:45

manager   ~0050937

Ok, thx for clarifying. Target set accordingly.

gazouteast

02-10-10 17:55

reporter   ~0051102

.

Aaargh !!!! Michiel :((

And there was me hoping this would be fixed in 2.10.12 and you punted it to 2.10.14

Not happy

.