View Issue Details

IDProjectCategoryView StatusLast Update
0015430phplist applicationInterface - Frontendpublic13-04-10 15:44
Reporteradrian15 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionFutureDevelopments 
Target Version4.0.xFixed in Version4.0.x 
Summary0015430: Login message not relative to phplist installation
DescriptionWhenever you change your password you get an email that tells you: To return, lick Home.

Home is a link that supposedly points to your phplist installation home.

That's not true it has hardcode: /lists/ so it is only valid in a default phplist installation which might not be the case when you have several installations in a single box.

The patch that I attach was made for revision 1703 but I see that the bug still persists in current svn revision: 1794.

I say that it is a major bug because it makes the installation unusable in non-default installations. People might be keeping trying to log in again in again till they check the wrong url on their browser.

adrian15
TagsNo tags attached.

Activities

12-04-10 17:19

 

svn_r1703_login_message_not_relative_to_phplist_installation.diff (933 bytes)
diff -urN svn_r1703_sin_punto_svn_cumulus_stage_2/phplist/public_html/lists/admin/login.php svn_r1703_sin_punto_svn_cumulus_stage_4_mensaje_login_apunta_bien/phplist/public_html/lists/admin/login.php
--- svn_r1703_sin_punto_svn_cumulus_stage_2/phplist/public_html/lists/admin/login.php	2009-11-29 16:50:16.000000000 +0100
+++ svn_r1703_sin_punto_svn_cumulus_stage_4_mensaje_login_apunta_bien/phplist/public_html/lists/admin/login.php	2010-01-14 17:18:24.000000000 +0100
@@ -62,7 +62,7 @@
       $row = Sql_Fetch_Row_Query($SQLquery);
       if ($row[0]) {
         echo("Your password was changed succesfully.\n");
-        echo("To return, click: <a href='/lists/admin/'>Home</a>.\n");
+        echo("To return, click: <a href='./'>Home</a>.\n");
         #Token deletion.
         $SQLquery=sprintf("delete from %s where admin = %d;", $GLOBALS['tables']['admin_password_request'], $row[0]);
         $query = Sql_Query($SQLquery);