View Issue Details

IDProjectCategoryView StatusLast Update
0015404phplist applicationAttachmentspublic20-01-10 14:43
ReporterElektordi 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version2.10.10 
Target VersionFixed in Version 
Summary0015404: Attachements in text emails
DescriptionI have changed the source code for adding attachements in both html and text files.
If you want, I will try to implement it a better way with a config value to decide if you want attachements or links in text mails.

But maybe there is a reason that only a link is put in text emails?
Additional InformationFor the quick & dirty way to add attachements to text mails:

edit admin/sendemaillib.php and comment the following lines:

785 to 787
    //if ($type == "text") {
    // $mail->append_text($GLOBALS["strAttachmentIntro"]."\n");
    //}

790 and 791
      //switch ($type) {
        //case "HTML":

843 to 847
         //case "text":
         // $viewurl = $GLOBALS["scheme"]."://".$website.$GLOBALS["pageroot"].'/dl.php?id='.$att["id"];
         // $mail->append_text($att["description"]."\n".$GLOBALS["strLocation"].": ".$viewurl."\n");
         // break;
      //}
TagsNo tags attached.

Activities

michiel

20-01-10 14:43

manager   ~0050823


Yes, if you want you can post the hack to the documentation http://docs.phplist.com/PhplistHacks, but in the main application I decided not to do this for the following reason:

if a user decides they want to receive text then that is often because they have a bad line or read it on their mobile or something like that. In that case, sending them attachments via email will be unpleasant.

Also, say you send 10.000 text emails and only 2000 open the attachment. That saves a lot of bandwidth as 8000 times the attachment will not be transferred.

Basically the text version should be as lightweight as possible.