View Issue Details

IDProjectCategoryView StatusLast Update
0015358phplist applicationSubscriber Importpublic19-05-15 17:23
Reportercrowdofone 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.10 
Target Version2.10.12Fixed in Version2.10.12 
Summary0015358: Import does not strip doublequote text delimiters when using 'import emails with the same values for attributes'
DescriptionBy default Openoffice Calc uses the text delimter " when exporting CSV files. When importing to phplist it appears not to remove these which results in email addresses that look like: "name@domain.com" instead of just: name@domain.com. The actual import itself goes fine but then later these doublequotes result in the addresses being regarded as invalid by phplist.

Line 407 of importcsv.php includes the code:

$line = str_replace('"', '', $line);

For whatever reason - i am not a competent enough coder to work out what's happening here - the code above either doesn't get called or does not have the intended effect.

As OpenOffice is a popular choice both for regular users and for those looking to convert xls files and export them as csv, i contend that this should just work without having to manually alter the text delimiter.

I have twice seen this effect. First when importing a large number of email addresses and then secondly through exporting a CSV file consisting of just two email addresses in an attempt to replicate the behaviour.

This appears consistent arcoss both 2.10.9 and 2.10.10.
TagsNo tags attached.

Activities

There are no notes attached to this issue.