View Issue Details

IDProjectCategoryView StatusLast Update
0015352phplist applicationUser Managementpublic19-04-10 19:49
Reportertitobrasolin 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.9 
Target Version2.10.12Fixed in Version2.10.12 
Summary0015352: Sort by 'entered' and 'modified' not working on page 'users'
DescriptionThe error is: "Database error 1052 while doing query Column 'entered' in order clause is ambiguous"

Looks like it happens only with MySQL 5.0.51 (we have phplists 2.10.9 on MySQL 5.0.41 works fine)

=Suggested fix=
  file: admin/commonlib/pages/users.php
  line 272: change
    $order = ' order by ' . $sortby;
  into
    $order = ' order by ' . "{$tables["user"]}.$sortby";
TagsNo tags attached.

Activities

There are no notes attached to this issue.