View Issue Details

IDProjectCategoryView StatusLast Update
0015349phplist applicationUser Managementpublic11-06-13 22:43
Reporterlwc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.x 
Target Version2.11.11Fixed in Version2.11.11 
Summary0015349: multi-byte characters in user attributes
DescriptionJust like http://mantis.phplist.com/view.php?id=1152 only for user attributes.

This is relevant for:
1) The usage of [attribute] in messages.
2) Searching by attribute in the list of users.
3) Displaying the search result of searching by attribute in the list of users
4) The user's preferences page
5) The admin's edit screen of individual users.

Things like such users are being unsearchable (by the relevant attribute) - even if you use slash in your search - is why I classified it as a major error.
TagsNo tags attached.

Relationships

related to 0001152 resolvedmichiel Need stripslashes when displaying the list name 

Activities

michiel

22-04-10 14:17

manager   ~0050956


I can't actually replicate this. But that might be because I don't have names that require quoting.

is it in attribute names that it goes wrong? Can you give and example?

lwc

06-05-10 11:21

reporter   ~0050993

For example, if (in UTF-8 encoding) your username is called ?'?? ??

lwc

06-05-10 11:22

reporter   ~0050994

Oh, how I wish you'd allow editing submissions. Anyway, I mean the bold part in http://www.google.com/search?q=%22%D7%92%27%D7%95%D7%9F+%D7%93%D7%95%22

michiel

05-06-13 17:00

manager   ~0052100


I just tried in trunk and for some reasons hebrew characters in user attributes don't work. So that needs looking at.

michiel

11-06-13 16:37

manager   ~0052134

I guess the error I had was on a non-UTF-8 DB.

I found the places to strip the slashes. But somehow the search still doesn't find them.

michiel

11-06-13 22:41

manager   ~0052135

I added a subscriber with name ????????? and searched for it and it found the subscriber.

Not entirely sure this is all fine, but resolving for now.

michiel

11-06-13 22:43

manager   ~0052136

mantis doesn't handle the characters, but it was "Newsletter" in Hebrew, which seems to have the quoted characters.

http://translate.google.com/#auto/en/%D7%A0%D7%99%D7%95%D7%96%D7%9C%D7%98%D7%A8%D7%99%D7%9D