View Issue Details

IDProjectCategoryView StatusLast Update
0015318phplist applicationBounce Managementpublic19-04-10 21:50
Reporterrobharrigan 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.12Fixed in Version2.10.12 
Summary0015318: Index needed on phplist_user_message_bounce table
DescriptionI've been experiencing some painfully slow processing time using
processbounces, I suspected it was due to a missing index and the large size
of the table (50000+ records). My response time improved dramatically,
finishing in 2 minutes instead of 6-8 hours, after adding another index to
the phplist_user_bounce_message table like so:

mysql> create index message_lookup using btree on
phplist_user_message_bounce (message);
TagsNo tags attached.

Relationships

related to 0015417 resolvedmichiel speed up bounce management by optimizing mysql tables and queries to use indices 

Activities

michiel

19-04-10 21:50

manager   ~0050938

the index already existed in the structure file, so new installs would get this, but I've added it to the upgrade code to be created, so that it'll apply to existing installs as well