View Issue Details

IDProjectCategoryView StatusLast Update
0015308phplist applicationMessage Send Processpublic19-04-10 20:55
Reporterrjc 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.10 
Target Version2.10.12Fixed in Version2.10.11 
Summary0015308: Embedding images in CONTENT section not working
DescriptionI've found an issue in v2.10.10 (which others have reported since v2.10.7 or 2.10.8). I believe it's started since the upgrade to the new version of fckeditor (2.6.3?).

Embedding images in the content section, which was added as a feature sometime after v2.10.4, was not working because the path was resolving incorrectly. I have found the fix for it, and just letting you know officially in Mantis so you can double-check and make adjustments in v2.10.11.

My discussion of the cause of the problem is here:
http://forums.phplist.com/viewtopic.php?f=7&t=10082&start=30#p63692

And the fix for the issue is here:
http://forums.phplist.com/viewtopic.php?f=7&t=10082&start=30#p63693
TagsNo tags attached.

Activities

jaime

04-08-09 14:30

reporter   ~0050704

I'm running v2.10.10 (latest stable) too and got the embedded images to work without much hassle by setting define("EMBEDUPLOADIMAGES",1) on the configuration file.

However that won't work, at least on my setup, when the queue is processed by a cron job running a php cli interpreter. The bug is in filesystem_image_exists() and get_filesystem_image() in class.phplistmailer.php. Both functions expect $_SERVER['DOCUMENT_ROOT'] to be set, which is true when the queue is processed in the web browser, but is FALSE on most server setups when running the script from the command line.

My temporary, quick and dirty fix was to set this:

if (empty($_SERVER['DOCUMENT_ROOT']))
$_SERVER['DOCUMENT_ROOT'] = '/var/www/vhosts/[FULL PATH TO MY DOCUMENT ROOT]/subdomains/phplist/httpdocs';

on my config.php file.

That fixed the issue when embedding images, but still won't work when attaching files (attachments). The problem is this time on sendermaillib.php addAttachments(). This:

if (is_file($GLOBALS["attachment_repository"]."/".$att["filename"]) && filesize($GLOBALS["attachment_repository"]."/".$att["filename"])) {

Won't work on many setups from command line if $attachment_repository is set to '/tmp' (as default). My fix was to set this on the config file:

$attachment_repository = "{$_SERVER['DOCUMENT_ROOT']}/uploadimages";
$tmpdir = "{$_SERVER['DOCUMENT_ROOT']}/uploadimages";

michiel

19-04-10 20:55

manager   ~0050935

this was fixed in 2.10.11