View Issue Details

IDProjectCategoryView StatusLast Update
0015290phplist applicationSubscribe Processpublic27-11-09 17:36
Reporterh2b2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.10 
Target Version2.10.11Fixed in Version2.10.11 
Summary0015290: v2.10.10 - Second subscribe window appearing when re-subscribing a previously unsubscribed user
DescriptionIf a previously unsubscribed user attempts to re-subscribe, a second window is displayed over the first.

This issue has been reported in http://forums.phplist.com/viewtopic.php?f=15&t=24579#p62107

Confirmed on my system
-
Additional InformationThis issue was previously reported for v.2.10.8 and 2.10.9, and was flagged as fixed in v2.10.10. See http://mantis.phplist.com/view.php?id=15240

See also: http://forums.phplist.com/viewtopic.php?p=58635#p58635

My system info:
phplist 2.10.10
Linux/Apache
PHP 5.2.3
MySQL 4.1.12
TagsNo tags attached.

Relationships

duplicate of 0015309 resolveduser4540 get blacklisted and see the html output when tring to subscribe 
child of 0015369 resolvedmichiel 2.10.10 initial patches 

Activities

yogoo

13-06-09 21:59

reporter   ~0050683

I posted a fix at
http://forums.phplist.com/viewtopic.php?p=58635#p63109

and uploaded the corrected file.

Briefly, the error is fixed by commenting out line 366 in lists/admin/subscribelib2.php

04-10-09 07:27

 

second_window_bug_patch.zip (516 bytes)

yogoo

04-10-09 07:28

reporter   ~0050745

Finally uploaded a patch (see above). I understand this is more timely for the developers to investigate the bug and the fix than my previous note.

The patch and explanation are also available on the forum:
http://forums.phplist.com/viewtopic.php?f=17&t=23452&p=63109#p63109

michiel

27-11-09 17:36

manager   ~0050787

revision 1698