View Issue Details

IDProjectCategoryView StatusLast Update
0015287phplist applicationMessage Managementpublic09-04-10 17:39
Reporterh2b2 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version2.10.10 
Target Version2.10.11Fixed in Version2.10.11 
Summary0015287: v2.10.10: FCKeditor doesn't load when opening the 'send a message' page.
DescriptionSeveral users reported FCKeditor didn't load when opening the 'send a message' page.

taydeko found the issue is caused by a couple of code lines in send_core.php
==== START QUOTE =====
On line 1034 and 1040 are:

//value="'.htmlentities(iconv('ISO-8859-1','UTF-8',$subject),ENT_QUOTES,'UTF-8').'" size=40></td></tr>
value="'.htmlentities(iconv('ISO-8859-1','UTF-8',$from),ENT_QUOTES,'UTF-8').'" size=40></td></tr>

I am not sure why 1034 is commented out, but if you replace 1034 with the contents of 1023 without the comment, and replace 1040 with 1024 without the comment, the program works fine for me. So it looks like something is causing a problem in the "iconv('ISO-8859-1','UTF-8',$from)" bit of code.
==== START QUOTE =====
Source: http://forums.phplist.com/viewtopic.php?f=17&t=24501#p61969
Additional InformationThe issue occurred on a system with $strCharSet=ISO-8859-1 and the following database settings:
character_set_client: utf8
character_set_connection: utf8
character_set_database: latin1
character_set_filesystem: binary
character_set_results: utf8
character_set_server: latin1
character_set_system: utf8

I couldn't reproduce this issue on my system which is fully configured for UTF-8 (see notes 0050565 and 0050579 of mantis issue 1644).


SOME REMARKS:
It seems to me the code changes made to fix issue http://mantis.phplist.com/view.php?id=15241 have introduced the current issue.

It is unclear to me why line 1034 has been disabled (commented), nor can I check on my system whether just uncommenting line 1034 would solve this issue.

I wonder whether the use of iconv -as in: htmlentities(iconv('ISO-8859-1','UTF-8',$subject) - wouldn't result in more trouble than it solves, for instance if someone would be using another admin page encoding than ISO-8859-1, like ISO-8859-7 which is used in greec.inc.

I also wonder whether hardcoding charsets is the best way to go. Please see my notes on this topic in http://mantis.phplist.com/view.php?id=1644
TagsNo tags attached.

Relationships

related to 0015463 resolvedmichiel Call to iconv() doesn't fail gracefully and prevents FCKeditor from loading 
child of 0015369 resolvedmichiel 2.10.10 initial patches 

Activities

h2b2

13-05-09 02:49

manager   ~0050646

It appears that just uncommenting line 1034 in admin/send_core.php should be enough to fix this issue.
 //value="'.htmlentities(iconv('ISO-8859-1','UTF-8',$subject),ENT_QUOTES,'UTF-8').'" size=40></td></tr>

See also: http://forums.phplist.com/viewtopic.php?p=62061#p62061

So, I guess this might well be just a typo instead of an issue with iconv. Even so, I have some doubts regarding the use of iconv to fix encoding issues since it again involves hardcoding.

h2b2

14-05-09 23:12

manager   ~0050648

Actually I spoke to soon. A number of users reported that just uncommenting line 1034 does not work on their system. Reverting to the old 2.10.9 code -i.e., without "iconv"- did work for them.

ref: http://forums.phplist.com/viewtopic.php?p=62072#p62072

h2b2

29-08-09 14:33

manager   ~0050724

The use of iconv() also appears to be the cause of trouble in these issue reports:
http://mantis.phplist.com/view.php?id=15324
http://forums.phplist.com/viewtopic.php?f=17&t=28038

h2b2

29-08-09 14:40

manager   ~0050726

The fix suggested by taydeko has been included in the patched lists/admin/send_core.php file available in this forum post: http://forums.phplist.com/viewtopic.php?f=3&t=24748#p62594

karma

21-10-09 04:21

reporter   ~0050758

I concur with the above. However, I might add that this is not a "minor" issue, since numerous postings and threads showing all sorts of different "fixes" exist in the forums (none of which worked for me, I might add, except for the send_core.php fix). For a detailed post containing my particular experience, see:

http://forums.phplist.com/viewtopic.php?f=3&t=28742

michiel

09-04-10 17:39

manager   ~0050860

bit hard to replicate, but I've applied the patch, so presumably it should be fixed