View Issue Details

IDProjectCategoryView StatusLast Update
0015241phplist applicationMessage Managementpublic13-04-10 22:27
Reporterenes 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.9 
Target VersionFixed in Version2.10.10 
Summary0015241: Subject will empty when we edit the message
Descriptionhello,
I've create a message, define a subject then save it. when I click the message for editing the subject will be empty. so I can't send the message if I try to send the message by editing window it sends with blank subject..

so I try to send it on the wiev secreen..

regards

 
TagsNo tags attached.

Relationships

related to 0001644 resolvedmichiel Subject error with UTF-8 encode in Traditional Chinese 
related to 0015324 resolvedmichiel Subject and From turn to Gibberish when saved not in English 

Activities

h2b2

11-03-09 00:31

manager   ~0050544

Seems related to http://mantis.phplist.com/view.php?id=1644

user4391

11-03-09 17:13

  ~0050545

There we try to reproduce this error, but every thing are working fine.
Maybe you can attach to us your config file, because its could be happening
because some parameters in your config file.

h2b2

17-03-09 22:23

manager   ~0050560

Please see note 0050558 for issue http://mantis.phplist.com/view.php?id=1644

h2b2

20-03-09 08:23

manager   ~0050567

See also note 0050565 for test details which may help reproducing the error

user4391

25-03-09 16:26

  ~0050601

trouble fixed, the problem was the use of htmlentities PHP function to display the saved message subject. The problem was in the use of htmlentities function.
I add an iconv() function call inside the call to htmlentities() to convert from ISO-... to UTF-8 because the database table of messages was created with the charset ISO-... and need to be converted to UTF-8 to apply the htmlentities() functionality.