View Issue Details

IDProjectCategoryView StatusLast Update
0015231phpList 3 applicationSubscriber Importpublic21-06-18 14:05
ReporterOGJuiceLoc Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.8 
Target Versionnext majorFixed in Version2.11.11 
Summary0015231: False warnings during test import with 'import emails with different values for attributes'
DescriptionThe warning described in http://mantis.phplist.com/view.php?id=3603 still occurs after modifying the code as directed in .../lists/admin/commonlib/pages/importcsv.php.

After attempting to import using Test Output a few times starting at .../lists/admin/?page=import2, the warning messages ONLY appear when "Show Warnings:" box is checked. I suppose this is what is meant in the description

------
If you check "Show Warnings", you will get warnings for invalid records. Warnings will only be shown if you check "Test Output". They will be ignored when actually importing."
------

This is being brought up again because this was supposedly resolved in 2005 but is not. It's just a matter of figuring out why (with or without the "-1" modification):
 
(sizeof($values)-1) != (sizeof($_SESSION["import_attribute"]) + sizeof($_SESSION["system_attributes"])

See attached snapshot. Lastly, it still occurs in the latest version 2.10.9.
TagsNo tags attached.

Relationships

related to 0003603 resolvedmichiel False warnings during test import with 'import emails with different values for attributes' 
related to 0006275 resolvedmichiel False warnings during test import with 'import emails with different values for attributes' 
related to 0003430 resolvedmichiel False warnings always reported during import 
related to 0016537 new Import not coping with "text \r\n text" ? 

Activities

11-02-09 09:46

 

OGJuiceLoc

11-02-09 09:55

reporter   ~0050427

Related to http://mantis.phplist.com/view.php?id=3430

michiel

12-05-11 15:30

administrator   ~0051324


I guess the best thing to do is to check that there's actually data in the "chopped off" columns and not give the warning if there isn't any.

silaspalmer

15-12-11 23:58

reporter   ~0051423

Attached is a slightly modified version of importcsv.php which resolves this issue, and is more compatible with excel CSV format.

silaspalmer

16-12-11 00:03

reporter   ~0051424

You can view the modified importcsv.php code here:
http://forums.phplist.com/viewtopic.php?f=7&t=5085&p=89890#p89890

(I don't have the permissions to upload files to mantis)

Cheers,
Silas.

michiel

02-02-12 01:59

administrator   ~0051450

I tried merging the code with the existing one, but there are so many changes, it makes it hard to see what to keep and what to merge.

I wonder whether the PHP function http://php.net/fgetcsv should be used, and whether it can handle the multi-line issue and double quotes as you outline.

michiel

04-06-13 16:46

administrator   ~0052089

applied 0006275:0051173 and that seems to resolve it. Thanks!