View Issue Details

IDProjectCategoryView StatusLast Update
0015222phplist applicationInternationalization (l18n)public23-03-09 15:43
Reporterh2b2 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.10.8 
Target VersionFixed in Version2.10.10 
Summary0015222: String 'All Active Lists' appears to be hardcoded in admin/send.php
Descriptionemmedi originally reported this hardcoded string in admin/send.php, line 103:

====== START QUOTE =======

    $list_content .= '>'.$GLOBALS['I18N']->get('All Active Lists').'';

This code does not allow a correct translation.

We must replace the line like that?
    $list_content .= '>'.$GLOBALS['I18N']->get('allactive').'';


====== END QUOTE =======
Source: http://forums.phplist.com/viewtopic.php?t=19734
Additional InformationThe above issue was originally reported for v2.10.5, but still seems to be valid for v2.10.8
TagsNo tags attached.

Activities

michiel

23-03-09 15:43

manager   ~0050590

no, it means that the string is not found in the language file.

in admin/lan/en/send.php add a line:

'All Active Lists' => 'All Active Lists'

and in all languages it can be translated