View Issue Details

IDProjectCategoryView StatusLast Update
0015212phplist applicationSubscribe Processpublic23-03-09 15:12
Reporterh2b2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.8 
Target Version2.10.10Fixed in Version2.10.10 
Summary0015212: UNSUBSCRIBE_JUMPOFF setting not functional even if UNSUBSCRIBE_JUMPOFF is set to 1 in config.php
DescriptionI ran a test on 2.10.7 and 2.10.8 with UNSUBSCRIBE_JUMPOFF" set to 1, both by unsubscribing from:
1. a ***personalized unsubscribe link*** (unsubscribe url + uid) contained in a message the user received (e.g. lists/?p=unsubscribe&uid=c2672b3f595..etc.)
2. a non-personalized link (e.g. lists/?p=unsubscribe)

In both cases the 'tell us why' textarea is displayed.

system info:
phplist 2.10.7 + 2.10.8
Linux/Apache
PHP 5.2.3
MySQL 4.1.12
Additional InformationThis issue was previously reported in http://mantis.phplist.com/bug_view_page.php?bug_id=15195
and closed as a being duplicate of http://mantis.phplist.com/view.php?id=2954

However, it seems to me this is NOT a duplicate of issue 2954 since testing the jumpoff setting with a *personal URL* (see above) will still display the 'tell us why' text area.

If you cannot reproduce this on your system, please let me know what additional information you would need to be able to replicate this.


NOTE:
This report would normally have been a feedback note to Mantis issue 0015195. Unfortunately the current Mantis settings do not seem to allow entering feedback notes anymore. If you do not wish to receive feedback notes in this manner, please provide an alternative.

TagsNo tags attached.

Relationships

child of 0015369 resolvedmichiel 2.10.10 initial patches 

Activities

h2b2

28-02-09 14:12

manager   ~0050528

This is a possible fix (for v2.10.9) suggested by rdaneel:

====START QUOTE====

line 717 in index.php
  } else {

should read:
  } elseif(!$_POST["unsubscribereason"]) {

====END QUOTE====
Source: http://forums.phplist.com/viewtopic.php?p=60065#60065

CS2

21-03-09 21:22

reporter   ~0050576

The suggested fix will probably work but I think that changing line 717 to:
} elseif (!UNSUBSCRIBE_JUMPOFF) {

might make more sense.

user4391

23-03-09 15:12

  ~0050584

the flag UNSUBSCRIBE_JUMPOFF never was consider in the process of unsubscribe user if the unsubscribe email was given.
Now, this flag is requested to define if the user need to give an explanation of unsubscribe reasons or not.