View Issue Details

IDProjectCategoryView StatusLast Update
0015211phplist applicationMessage Send Processpublic19-05-15 16:23
Reporterdavideg 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.8 
Target VersionFixed in Version2.10.10 
Summary0015211: STACKED_ATTRIBUTE_SELECTION "," error on values
Descriptionwith STACKED_ATTRIBUTE_SELECTION = 1, in the message composition window, when i add a criterion that's not a checkbox (so i get the error with select and gr) i get an sql error on ",1".
Trying to to a little debug i've found that the problem is in send_core.php because the sql is so composed:
--
in values (,1)
--
if i add more conditions the sql get:
--
in values (,1,2)
--
so the error is that it puts an additional comma at the begin.
I've do a workaround adding this at line 822:

--
$crit_data["values"] = preg_replace('/^,/','',$crit_data["values"]);
--

That's obviusly a workaround but it works and can get closer to the problem solution.

Regards.
TagsNo tags attached.

Relationships

related to 0015454 resolvedmichiel database error 1064 when stacking attributes in 2.10.12 

Activities

There are no notes attached to this issue.