View Issue Details

IDProjectCategoryView StatusLast Update
0015192phplist applicationSubscribe Processpublic16-12-08 17:02
Reporterrai 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.5 
Target VersionFixed in Version2.10.9 
Summary0015192: Confirm Email Alert with no fieldname when Empty
DescriptionIf the user subscribe or change his data, an empty confirm email field will not show the field name in the alert window.

The fault is in file admin/subscribelib2.php. At line 702 in the last Globals variable is a $-sign, generating a variable in the array:

false:
  $GLOBALS["strConfirmEmail"],htmlspecialchars(stripslashes($_REQUEST["emailconfirm"])),$textlinewidth, $GLOBALS["$strConfirmEmail"]);

right:
$GLOBALS["strConfirmEmail"],htmlspecialchars(stripslashes($_REQUEST["emailconfirm"])),$textlinewidth, $GLOBALS["strConfirmEmail"]);
TagsNo tags attached.

Relationships

has duplicate 0012800 resolveduser4377 When Display Confirm Email is selected and field is left blank, the javascript message does not display correctly. 

Activities

user4377

16-12-08 17:02

  ~0050264

Thanks for the contribution. The problem was fixed that way.