View Issue Details

IDProjectCategoryView StatusLast Update
0015184phplist applicationUser Managementpublic03-02-11 19:06
Reportermiels 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.7 
Target VersionFixed in Version2.10.9 
Summary0015184: "list of all users" is empty
DescriptionWhen clicking on "Users" in the column at the right, the result is an empty userlist. The top states "156 users", but not a single one shows up.

This feature did work before I upgraded earlier today from 2.10.2 to 2.10.7.
Additional InformationBtw: version 2.10.7 isn't listed in the Mantis "product version" pull-downlist.
TagsNo tags attached.

Activities

h2b2

20-11-08 19:21

manager   ~0050243

A number of user have mentioned having similar problems with displaying the user list after an upgrade to ver. 2.10.7

For more details, see these forum threads:
http://forums.phplist.com/viewtopic.php?t=22619
http://forums.phplist.com/viewtopic.php?t=21923
http://forums.phplist.com/viewtopic.php?t=21981

Since it appears that not all users that upgraded came across this problem, I suppose it might be related to their specific phplist configuration, or server setup.

Unfortunately, most users still forget to include basic info on their server configuration, and this will of course not help speed up the troubleshooting process.

Anyway, the above threads might perhaps provide some indications for troubleshooting.

e28eta

26-11-08 08:58

reporter   ~0050248

I'm pretty sure I've figured it out. I've never coded in php, and I know _very_ little about phpList itself.

The bug is in the file: admin/commonlib/pages/users.php, starting on line 384:
    ### allow plugins to add columns
    foreach ($GLOBALS['plugins'] as $plugin) {
      $plugin->displayUsers($user, $user['email'], $ls);
    }

The two plugins that came packaged with phplist do not implement the displayUsers method, and the users page craps out at this point.

I tried two different fixes, and both worked. I'm not sure which is appropriate, so I'll offer them both.

First, check to see if the method exists before trying to call it:
    ### allow plugins to add columns
    foreach ($GLOBALS['plugins'] as $plugin) {
      if(method_exists($plugin, "displayUsers")) {
        $plugin->displayUsers($user, $user['email'], $ls);
      }
    }


The second option, modify admin/defaultplugin.php. Add a method displayUsers($user, $email, $listing), that does nothing, to the phplistPlugin class. I'm assuming subclasses can override it to provide desired functionality (again, I know nothing about php).

michiel

16-12-08 12:31

manager   ~0050260

yes, of the two options, the second one is best:

edit admin/defaultplugin.php and add the empty method.

user4377

17-12-08 11:12

  ~0050266

Ok, Empty method added to the class.