View Issue Details

IDProjectCategoryView StatusLast Update
0014970phplist applicationMessage Send Processpublic30-05-12 20:54
Reporterjvarrone 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.5 
Target Version4.0.xFixed in Version2.11.7 
Summary0014970: "Duplicate" emails selected but not counted in total sent. Message remains "inprocess".
DescriptionWhen PHPlist selects emails to include during processqueue, it includes emails previously marked as duplicates. e.g. where the email name is "duplicate1 joe@somwhere.net". The duplicates are included in the total number of emails to send. However, since they're never sent, they are counted in the actual number of emails sent. Therefore the message stays in the inprocess state and the message status indicates x remaining emails to send. Where x is the number of duplicate emails.

Recommendation: Include logic during selection process to include these in the "users who can be excluded from this processqueue run". Or, just exclude them from the selection process up front.
TagsNo tags attached.

Relationships

related to 0010174 resolvedmichiel Processqueue gets stuck in infinite loop with concatenated email addresses 

Activities

There are no notes attached to this issue.