View Issue Details

IDProjectCategoryView StatusLast Update
0001448phpList 3 applicationCampaign Send Processpublic20-05-05 03:41
Reporterpfleming 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0001448: Message throughput dramatically dropped after upgrade to 2.8.9
DescriptionI just upgraded to version 2.8.9 after running 2.x.x successfully for months.

Before the upgrade, the old version of phplist would send out AT LEAST a couple hundred e-mails a time everytime I manually processed the queue (my distribution list is about 3000 e-mails long).

Now that I've upgraded, version 2.8.9 is only sending out approximately 50 e-mails at a time.

I thought this may have had something to do with me processing the queue manually, so I configured a CRON job to process my queue. The cron job is running every 10 minutes and phplist is still only sending out 50 e-mails at a time.

Batch processing is definitely off.
Additional InformationI was manually processing the queue using Internet Explorer on a PC as well as a Mac (latest versions).

Finally configured the CRON job and having the same problem.

Absolutely nothing else had changed with my host or my PHPlist configuration settings since I upgraded to 2.8.9.

I did add 1000 news e-mails to my list right before the upgrade to 2.8.9.
TagsNo tags attached.

Activities

michiel

19-07-04 17:16

manager   ~0001562

few questions,
do you have your own machine (ie no ISP who has set batch limits)
what 2.x.x version did you run before?

pfleming

19-07-04 17:46

reporter   ~0001564

I'm pretty sure I was running 2.6.4. I host the account off of powweb. Always have.

Powweb has a very active community support board. If this problem was a server config setting on their end, folks on the message boards would be screaming bloody murder. (forum.powweb.com).

pfleming

29-07-04 03:59

reporter   ~0001590

I just did a new mail out. The first since I posted my issue. I upgraded to phplist 2.8.10 and I'm having the exact same problem.

After the cron job fires, about 55 messages are processed. (but 1/2 the time, phplist doesn't send ANY messages).

I see a bunch of these in my eventlog:

"A process for this page is already running and it was still alive 1209 seconds ago"


If you have any suggestions I could try for you, or if you would like to look at my installation, send me e-mail.

pfleming

29-07-04 23:33

reporter   ~0001593

As you can see below, only 42 messages sent.

[Thu 29 Jul 2004 14:35] [] Started
[Thu 29 Jul 2004 14:35] [] A process for this page is already running and
it was still alive 1392 seconds ago
[Thu 29 Jul 2004 14:35] [] Sleeping for 20 seconds, aborting will now quit
[Thu 29 Jul 2004 14:35] [] A process for this page is already running and
it was still alive 1412 seconds ago
[Thu 29 Jul 2004 14:35] [] Sleeping for 20 seconds, aborting will now quit
[Thu 29 Jul 2004 14:35] [] Processing has started, 1 message(s) to process.

[Thu 29 Jul 2004 14:35] [] It is safe to click your stop button now, report
will be sent by email to listreports@**********
[Thu 29 Jul 2004 14:35] [] Processing message 37
[Thu 29 Jul 2004 14:35] [] Looking for users
[Thu 29 Jul 2004 14:35] [] Found them: 4364 to processProcess Killed by
other process
[Thu 29 Jul 2004 14:36] [] Process Killed by other process
[Thu 29 Jul 2004 14:36] [] Script stage: 5
[Thu 29 Jul 2004 14:36] [] 42 messages sent and 3729 messages skipped

michiel

30-07-04 00:04

manager   ~0001594

messages that are "skipped" are messages that have been sent before. phplist avoid duplicating a message to a user, which is one of it's most important features, whihc is why it "skips" some messages. So all the "skipped" messages have actually been sent.

michiel

30-07-04 00:06

manager   ~0001595

also, the main reason probably that things are slow is that you seem to be firing off the process queue process several times. Just the once, maybe repeated after an hour or so to make sure, should be fine. Don't keep clicking that "processqueue" link every single time. In order to avoid stalling your server phplist only allows one process at a time.

pfleming

30-07-04 15:28

reporter   ~0001602

Do you have any comment on what could be the reason why I could hit processqueue on the 2.7.x versions and have 200+ mails go out at a time, but when I processqueue on the 2.8.x versions, I get 55 or less mails going out at a time?

I will modify my cron to fire every 60 minutes as opposed to every 15 minutes, but I'm worried that it will take ever longer to send to all my 4000 users. It took over 24 hours to complete this last mail.

pfleming

13-08-04 16:39

reporter   ~0001679

I just downgraded to version 2.7.2 and phplist is once again blissfully sending 100's of e-mails each time I process the queue.

pfleming

03-09-04 02:15

reporter   ~0001767

I see another user post in the forums experiencing the same problem I am since the batch processing stuff was added in the 2.8.x versions. They are using a different hosting company than I am, so it's not just me. Please review.

http://www.phplist.com/forums/viewtopic.php?p=4346#4346