View Issue Details

IDProjectCategoryView StatusLast Update
0014253phplist applicationStatisticspublic03-06-13 21:15
Status resolvedResolutionduplicate 
Product Version2.10.5 
Target Version4.0.xFixed in Version 
Summary0014253: clicktracking totals: sent msgs is calculated wrong (especially for RSS msgs)
Descriptionmviews.php: the SQL (which was already changed in bug #6531) is still not correct, it should include a where/having-condition to only select the msgs which were actually sent. If status is being counted, it has to select "where um.status='sent'", or else the stats will be horribly wrong for msgs with 2 or 3 RSS frequencies.

TagsNo tags attached.


duplicate of 0016796 resolvedmichiel Review statistics exactness 
related to 0006531 resolvedmichiel statsoverview.php and mviews.php display incorrect totals because 'usermessage' table 'entered' field is NULL 
has duplicate 0011267 resolvedmichiel CLicktrack totals are incorrect 



24-04-08 08:23

reporter   ~0045691

this also affects statsoverview.php ...

by the way, statsoverview and mviews are basically the same file, I suggest merging them to stats.php with different function blocks for voerview and details...

also code which does nothing should be assessed:

$timerange = ' and date_add(msg.entered,interval 6 month) > now()';
$timerange = '';